Cannot turn off development build logo

Hi there,

I’ve built a web player version of my game, and no matter what I do, the development build logo still appears on the bottom right corner.

Here are the things I’ve tried based on my search:

  • make sure the Development Build checkbox is unticked - checked, it is unticked

  • remove the build before building - done, does not resolve problem

  • remove all generated files and folders (bin, Library, Temp, solution files) before building - done, does not resolve the problem

  • remove the Library/EditorUserBuildSettings.asset file before building - done, does not resolve problem

  • set the MonoDevelop build type to Release and rebuild solution - done, does not resolve problem

  • make sure the Development Build checkbox is unticked in other build types as well - checked, they are unticked

The weird thing is, I do not get this problem with other projects.
Can anyone please help me with this problem?

Thanks!

Update: this apparently affects only web player mode, it works fine with other platforms. However, it also affects all projects. Maybe this is a hidden setting in Unity?

well you can still go like: make a new folder and copy Assets and ProjectSettings folders of your project into it (disregarding all the other files). then from the Unity >> Open Project >> go to your newly created folder/project >> hit open. build. you may have some problems tho, not sure what kind.

Finally found the solution through this page: http://docs.unity3d.com/Manual/WebPlayerChannels.html

Alt + right click, then uncheck Development setting. When it’s checked, it overrides the build settings.