Cant Add Script (or create any new scripts) Javascript

I know this is a common issue but I have spent quite a long time researching various people with similar issues and none of them applied to my particular situation. I tried to create a new script and rename it within MonoDevelop. Unity gave me an error about changing the “.meta” file for the NewBehaviourScript.js and I could not attach the script to anything without an error so I renamed the file to its original name. The issue still remained. I tried restarting Unity and deleting the script but all new scripts cannot be attached to objects. Every time, I get the error message:


I am currently completely unable to create scripts at all. Does anyone know how to fix this issue? To be clear, I am getting this error now with any script that I create, even if they are empty and freshly created.

Here is a screen grab of an empty, just created, not renamed file producing this error.

i don’t know if this will help But how about you try to not rename it?

I managed to fix my own issue by updating Unity to the most recent version. Still not sure exactly what caused it.