Can't apply other materials to imported meshes

There seem to be a lot of threads on trying to import materials along with .fbx files but I seem to be having the opposite problem. I have a material, and if I apply it to a primitive object it works fine, but if I create a box in Blender and import it, create an object from the mesh out of the fbx, and then apply the same material, it just displays one solid color.

I thought maybe the size difference was causing it to have problems but changing the tiling up and down didn’t help. I’ve tried changing the texture and it almost seems to be grabbing one pixel out of the texture and applying that to the entire object. I’ve also tried telling it not to import materials from the fbx.

I’ve just started using Unity so I may be missing something basic, but I’ve read through the manual and the reference and a few threads on here and I don’t see anything that helps.

Turns out I just needed to add in UVs.

Welcome to the Unity!

First, mesh is just an asset that stores geometry data, it can’t realy “have a material”. The material in this case would be a property of the mesh renderer.

When you import an FBX, it appears in the unity with an icon similar to prefab and contains the entire fbx hierarchy (that’s because FBX is not a simple mesh, it has a structure)
If you want to modify this imported object, ideally put it into scene and then turn it into prefab of your own. This allows you to edit the object (eg. change renderer materials, add components) and will also prevent losing your changes if you reimport the FBX.