Can't build game after admob

So I’ve made a game for android. It currently has Unity Ads but I want to switch to admob. The process is really simple but when it’s time to build I get wierd errors. Basically I think the problem is that I already have a package in my project that uses Android Manifest and I also heve the External Dependency Manager already installed. I think Admob just overrides these. Hopefully, I made a backup of my project just before I imported the admob package so if I make a mistake I can start again from this backup. Still I’m not very experienced with android development and I need help with this problem. Thanks!

When i remove the plugin the app runs perfectly, but when I add the Admob plugin the app wont launch at all, I also have Google Games Service in my game, and I have also added the app ID to the manifest. I am quite new to unity, and have spent several days trying to solve this issue with no success. Any help would be appreciated.

Have you fixed it? I have the same problem

I had the same problem several days ago, i had a backup (package).I created new project then import my own package than installed admob and it worked. The problem was as mentioned, unity ad package and admob package all messed up. Even if i delete unity package.