Can't build with simulator SDK selected!

I’m having problems when trying to run my game on an Iphone simulator in Xcode. I have succesfully build the game for a real device (an Iphone 5), where it works just fine.

However I need to acquire screenshots from different screen resolutions (different ‘devices’), since that is required in order to publish the game to the App Store (which I intend to do), and since I currently am not in possesion of all of these devices IRL, I have decided to run my game on the simulator in order to obtain the required screenshots.

This is where my problem occours!

I can’t build the game for the simulator, the build keeps failing.
I get this error: “linker command failed with exit code 1 (use -v to see invocation)”
I have searched the web for answers and tried all sorts of things:
I have tried to clean my project, delete the contents of DerivedData and disable bitcode.
However none of this worked, I still get the same error.

Recently I found out that setting the Target SDK to “Simulator SDK” instead of “Devide SDK” in Other Settings under Player Settings (inside of Unity) could resolve my problem, and enable me to build succesfully for the simulator.
However the “Build” button in the build settings window isn’t interactable, above it is a warning saying “In order to build the Xcode project for Simulator make sure that either GLES2 or GLES3 is added to the ‘Graphics APIs’ list because currently Metal is not supported in the Simulator.”
How to fix this?
How do I add GLES2 or GLES3 to the ‘Graphics APIs’ list?

I am relatively new to Xcode, and I would greatly appreciate any help!

Bottom line:
My game builds and runs on a device, but I can’t build it to the Simulator.
Is there other ways than those mentioned above to fix the “linker command failed with exit code 1 (use -v to see invocation)” error?
How do I add GLES2 or GLES3 to the ‘Graphics APIs’ list?

Thanks in advance.

Open IOS Player settings and find Graphics API’s check mark. Uncheck it and add GLES3 there. Now Unity should be able to build your project. @unity_43dx8xcwLzm_lQ


I tried it but I get the warning message that GLES2 or GLES3 are not supported for Linear Colour Space only Metal is supported. Any help for that?