Can't code on Mac: "The reference assemblies for .NETFramework,Version=v4.7.1 were not found "

Hey everyone, so with every new Unity Project I create, my Visual Studio Code tells me that

“Some projects have trouble loading.
Please review the output for more
details.”

Now the issue seems to be this:

The reference assemblies for
.NETFramework,Version=v4.7.1 were not
found.

And there is even a solution provided:

To resolve this, install the Developer
Pack (SDK/Targeting Pack) for this
framework version or retarget your
application. You can download .NET
Framework Developer Packs at
.NET SDKs downloads for Visual Studio
The only issue? The only available builds of the .NET for Mac OSX (my laptop) are 3.5 and 5 (preview), but no 4.X. I’m really confused and have found no solutions to this.


I can’t use VSCode like this either. Is there a fix for this I am missing? Or do I have to switch code editors?
Any help would be greatly appreciated.
Thanks!

https://tkymx83.hatenablog.com/entry/2020/08/23/170913

Here you can find the solution to the problem. I have just done it and it worked wonders. Hope it helps you too:3