can't connect to iPhone via Unity 5 remote with usb 3.0 ports

Ok, so apparently unity will not run on an iPhone using unity 5 remote since newer MacBooks have 3.0 usb ports vs 2.0. When I go to the editor only “any android device” is available. Here is my setup:

-iphone 6s, all updated

-Unity 5.3.6 (my partner is on 3.5, only difference)

-Macbook Pro 15 in El Capitan 10.11.4

And again, I don’t have an iOS option. Ive looked at all other questions but none solve this problem - is there a way to use unity 5 remote with only 3.0 usb ports? Is there an adapter I can buy?

Need some help here.

Heads up for other people that try to make it work on PC - you need iTunes, not joking!

Have you tried what the manual says about not being able to connect ios to osx??

The editor doesn’t connect to the iOS device on OSX

First, make sure you have iOS Target Support installed. Even if you are not creating builds for iOS, you must still have iOS Target Support installed to connect to Unity Remote on iOS devices.

To establish the connection to the iOS device through USB, Unity uses a 3rd party utility (iproxy) which is known to misbehave occasionally. You can try the following to fix the problem:

Reconnect the device.
Restart the device.
Go to the Editor settings (menu: Edit > Project Settings > Editor) and in the Unity Remote settings, briefly switch the device to Any Android Device and then back to Any iOS Device.
Restart the Unity editor.
Quit the Unity editor, open the Terminal and execute the command killall unityiproxy. Then, restart the editor again.
In most cases reconnecting or restarting the iOS device is enough to restore the connection.

i think it is in the part where you got to make sure ios development is enabled.

Still not working, trying to connect iPhones 11 Pro and Mac OS Catalina.