Can't disable CrashReport API

Hey guys,

I’m trying to implement Backtrace.io into my iOS project and one of the requirements is disabling the CrashReport API in the player settings. However, this option is grayed out for me.

I’ve tried enabling “Disable Editor Analytics” and I’ve made sure that I’ve disable Unity Cloud Analytics but I still can’t disable the crash reporting.

I’m running Unity 2022.3.18f1

Thanks in advance for any help.

Hallelujah! I figured it out.

Long story short, you need to add Unity Cloud Diagnostics to your project and then remove it. That will give you access to the Enable CrashReport API checkbox.

  1. In the editor go to Window → General → Services
  2. Add Cloud Diagnostics
  3. Select “Configure” in the upper right.
  4. Select your organization name (should be your Unity Login name)
  5. Select create new cloud project.
  6. Go to https://cloud.unity.com/
  7. Find the project you just made and archive/delete it
  8. Go back to the unity editor and disable Cloud Diagnostics in the services section in project settings
  9. Go to Window → General → Services and remove Cloud Diagnostics