Can't download Burst 1.3.0

I wanted to give Unity DOTS a try. I have successfully downloaded all the essential packages, like Burst, DOTS Editor, Hybrid Renderer, Entities, Collections etc. But then, strange errors had occured in my console:

I had read on the Internet that I need to update the Burst Compiler to preview version 1.3.0. And here’s where the true problem started. For an unknown reason, Unity couldn’t update the compiler and it had been stuck in an endless updating process. I tried everything. Restarting Unity and my PC, re-downloading Burst, creating empty project, turning off my firewall, running the Package Manager Diagnostics tool. I even decided to leave Unity updating the compiler for the whole night. Neither of these gave me any result.

Believe me or not, but when I was writing this question, the download window had popped up. But now, Unity is frozen in this state and I cannot do anything other than just close it. 155779-2.png

PS

Sorry for my harsh English :slight_smile:

Same problem here. The last version I have available to download is 1.2.3 but I need the version 1.3.0 to get collections like NativeList<> work as com.unity.collections seems to be no longer available

same problem

If Burst was already part of your project and you try to update it, package manager won’t be able to update it and so you could end-up with the errors you describe.

Usually to recover, you need to follow the steps:

  1. Close the editor (just after the update). If the editor is stuck, you can kill it.
  2. Remove the Library folder entirely.
  3. Restart the editor. ((In case of a doubt, before restarting, you can also double check that the manifest.json does actually contain the new burst that you are using)

We hope to fix this annoying issue in a future version of Burst.

For a second there I thought I was going to have this problem again with 1.3.0 preview.13 because it seemed like Unity hung but then it finished and just required a restart.

I learned something important here. Keep my project as small as possible (meaning worry about graphics, music, and other non-gameplay large files at the end) because deleting the Library folder and having it reimport can take a very long time with larger projects.

Really annoying since this is starting to become a regular uncertainty where backing up just means really long trial and error sessions just to get a PM package working.

open MyProjectRoot/packages/manifest.json and change the line

"com.unity.burst": "1.2.3",

(or whatever your burst version is) to

"com.unity.burst": "1.3.0-preview.13",

there might be more updates/previews in the future after this answer is posted, see Changelog | Burst | 1.3.9

Tried both the suggested solutions; neither one works.

I’m running Unity 2019.3.15f1 on Windows 10.,Tried both the suggested solutions; neither one works