Can't edit imported terrain (dae. or fbx.)

Hi everyone,

I’m quite a beginner in Unity and I mostly used it to export terrains (.dae or .fbx) from Sketchup or Mapertive directly to Unity. Everything worked well until today when I suddenly can’t edit terrain.
I’ve used every same procedure (Assets-Import new asset-Set terrrain and Terrain colider–Resize…) as before. Also tried reinstalling everything and just nothing works as it did.

As far as I know, you can’t import a model as a terrain object. Those are two separate concepts in Unity. The Terrain component generates it’s own model, and can only import from a heightmap.

I’ve solved it!
I downloaded object2terrain javascript, made flat terrain in unity, import my “fbx terrain”, use object2terrain and everything works now (except painting brush but i’ll figure that out).

If anyone is interested into making terrains I can highly recommend Mapertive. It’s a free tool which lets you export terrain to 3D (.dae). You can then pre-edit (add detail in mesh) it in sketchup (save as .fbx) and import it into Unity the way I wrote above.
It’s better than import from Google Maps because you can make huuuge terrains (one on a picture should be a bit less than 20 square kilometers) and i find it more accurate than exporting it from > raw > unity terrain.

If you want more info feel free to contact me.