Can't get a component from a parent!!

In unity I am making a 3D game where tanks are fighting each other for the enemy tank is a blender model that I imported to unity and like one all of the shapes I have made for it are children of the bad tank prefab I made a script that when the bad tank is shot all of the parts get detached and have explosion force added to them so it appears as though the tank is falling apart. In the script I need to get a reference to the parent’s script so that it can know when to fall apart I used to do that with GameObject.Find but since
I want to spawn a bunch of bad tanks every wave I can’t do that I tried many, many, many times and in varying ways to get the script through the GetComponetInParent command but it keeps saying that the object reference is not set to a instance of an object and I don’t know what to do. Here is the script.

public class Detach : MonoBehaviour
{
private BadTankScript badTank;
private Rigidbody rb;
private Transform explosionPos;
// Start is called before the first frame update
void Start()
{
explosionPos = gameObject.transform.parent.parent.transform;
badTank = //getting the parent’s script here.
}

// Update is called once per frame
void Update()
{
    if (badTank.queue == true)
    {
        transform.parent = null;
        rb = GetComponent<Rigidbody>();
        gameObject.AddComponent<Rigidbody>();
        Invoke(nameof(Force), 0.1f);
        Invoke(nameof(Delete), 4);
    }
}
void Force()
{
    rb.AddExplosionForce(2, explosionPos.position, 6, 0.3f, ForceMode.Impulse);
}
void Delete()
{
    Destroy(gameObject);
}

}`

GetComponentInParent<>() should work ok. I’ve never had a problem with it. Is your script on a direct parent or is it on another branch of the hierarchy?

You might find it’s better to get the transform of the GameObject by other means and call GetComponent<>() on that. I notice that explosionPos is equal to the parent.parent. If this is the GameObject with the script it might be easier to call explosionPos.GetComponent<>();

BTW The line that assigns explosionPos can be simplified to

explosionPos=transform.parent.parent;

It finally worked!! thank you so much! : )