Cant get white background to be transparent on my image

I’ve tried everything to get rid of the white background for my player’s sprite but even though I set up an alpha channel in the psd file by selecting the inverse of my image but the background still isn’t transparent. I’ve tried using png, psd and jpeg but nothing I do works.

In the import settings, try changing the ‘Texture Type’ to ‘Sprite (2D and UI)’.