Can't import any packages?

I have just downloaded the free version of Unity 4.2 onto my computer, and I want to import an fps controller package. However, it gives me the error ‘The server was unable to build the package. Please re-import.’ Then after that, it can’t connect to the asset store at all. My internet is working fine, and I’ve tried with some other packages but with no luck.

Any help would be appreciated.

I logged into the asset store WINDOW>ASSET STORE then clicked the download button and I had to accept the user agreement. After that I was able to download within the Unity program without having to go through WINDOW>ASSET STORE.

do you already have an older copy of the package you are trying to import in your project? if so you may need to delete it first.

you can also try to click the drop down in the package’s asset store page and choose “download only” option instead, and then manually import it into the project from the assets tab in unity.

If you see an exception in the console saying that you didnt login or an 401 http response. Make sure you log in first to the asset store. Try to close unity. Open it back up. Go to Windows->Asset Store. Then click login.

I had a similar problem that was because I hadn’t accepted a new user agreement. When I logged into the store through unity I was presented with the new license agreement, then imports started working.

Same problem (macOS and Unity 5) plus also the blank Asset tore tab. Here’s the workaround I used that finally worked: The penguin and the apple: Unity Asset Store issue (Updated)

Just Reinstall the program or if it doesnot do any thing get a new windows.