Can't import assets

I get this error whenever I try to import assets.

Failed to import package with error: Couldn't decompress package
UnityEditor.Web.JSProxyMgr:DoTasks()

draging the assets in doesn’t work either.

When it happened to me it’d just not downloaded correctly. Here’s what to do if it’s the same problem:

Go to the asset store. At the top bar you’ll see a download icon between the house and shoping cart icons, that’s the “Toggle Download Manager” button. Hit it and it’ll get you a list of the things you’ve tried to or already downloaded. hit “Download” on your asset (or deleate it if it’s already marked as downloaded) and then when it shows a green bar with 100% on it it should let you import.

You can try to reinstall unity(maybe you have deleted some files/folders from unity) or log out and log in again. You can also try to open it in your browser(try firefox and chrome) and if you already do, try to open it via window-assets store.

I tested other solutions posted in this and other posts, but it still didn’t fix it for me. However, I tried something else and then I was able to import packages without a problem again. It could be a different problem if this solution doesn’t work for you.

I had Unity installed and my previous projects on the C: drive. After I saved a new project on Onedrive, I couldn’t import packages, and it was showing me that same error message.

So then I finally created a New Project on the C: drive, and importing packages worked once again.

Are you using 32 Bit Editor?

This has been a bug in the past (unsure if they’ve fixed it or not), but you’d see this error when decompressing large assets.

So, if you’re using 32 Bit Editor, can you switch to 64?

For me this turned out to be because of an antivirus program - Bitdefender was blocking 7zip from decompressing the file. I added 7zip to the whitelist in Bitdefender and it worked.

Seems this problem is worse than ever. I’m on 2018, never had this problem with older versions of Unity. Now, I ALWAYS have to download packages multiple times. The one I’m trying to import now, I’ve already downloaded it ten times, and it ALWAYS fails 7-zip test. I know there’s nothing wrong with my machine, because I can test all the other packages I have, and they do not fail. It’s just when downloading new stuff. How is it that the developers at Unity can’t implement a better uploading system !@#$%

I have the same problem and I think I know What caused it, I was downloading Enviro Sky an dweather from the asset store, and I accidently hit cancel, after I tried to redownload, i Startet having this error:

Failed to import package with error: Couldn’t decompress package
UnityEditor.Web.JSProxyMgr:DoTasks()

Any Ideas on how to fix it?