Can't import package

I recently tried downloading and importing the recent unity 3d game kit package. It downloaded successfully but i can’t seem to import it. When i do it gives this error: Failed to import package with error: Couldn’t decompress package UnityEditor.Web.JSProxyMgr:DoTasks() and when i double click the error it says Nothing to import :All assets from this package are already in your project. I tried manually importing it by dragging and dropping it in the project view with no success. I changed the package location yet no success. And it’s only happening with this particular package. I downloaded and imported it’s 2d counterpart successfully as well as as other custom and in-built packages.
P.S.
I also tried downloading it multiple times. Someone pls help. Also i’m running the latest unity 2018 editor.

Does this help? Can't decompress package Unity 2017.1.f3 - Questions & Answers - Unity Discussions

No, it didn’t. I just don’t understand. All other packages are being imported successfully with the exception of this one.

set a large paging file like 30 gb o without paging file if you have a lot of ram