Can't install iOS Build Support

Hi,
I'm trying to get a Unity project onto my iPhone. I went to Build Settings and tried to switch the project to the iOS platform, but it says there is no iOS module loaded. I opened the Unity Download Assistant and tried to download only the iOS Build Support, but I got an error.

"An error occurred while running scripts from the package “UnitySetup-iOS-Support-for-Editor-5.3.4f1.pkg”."

Please tell me how I can load the iOS module. I'm trying to make a virtual reality environment in Unity, but I need to be able to get it onto my phone.

Thanks.


http://netstorage.unity3d.com/unity/e87ab445ead0/MacEditorTargetInstaller/UnitySetup-iOS-Support-for-Editor-5.3.2f1.pkg

1 Like

Ahh getting the same issue here but on 5.3.4f1

I'm guessing there's something wrong with the OSX installer...

@anguszhu I don't suppose you have the direct link to UnitySetup-iOS-Support-for-Editor-5.3.4f1.pkg as you've linked the one for 5.3.2f1 ?

//edit
Doh my issue was because I have multiple versions of Unity installed & the main one I'm using is 5.3.3f1
So it was trying to install the 5.3.4f1 iOS build support in the 5.3.3f1 app.

Check your install.log mine contained the following:

installd[291]: ./preinstall: Version: 5.3.3f1
installd[291]: ./preinstall: Expected: 5.3.4f1
installd[291]: ./preinstall: Unity version is not compatible with this component

It's a shame that that error doesn't bubble up to the installer GUI.

1 Like

I can't even get the download to complete for 5.3.5.f1...

Little old now, but was failing trying to install 5.3.5f1

Turns out the Unity app has to be located in /Applications/Unity and has to be called Unity.app

To find the version number the pre install script looks specifically at
$DSTVOLUME/Applications/Unity/Unity.app/Contents/Info.plist if that files doesn't exist the installer fails without any indication as to why

8 Likes

Thank you, this helped me install the IOS Build Support successfully! I have 4 versions of Unity installed and I had to change the folder name back to "Unity" for the version I was adding the IOS Build Support. The folder name was "Unity 2017.2Of3". I name each application folder a version to identify them.

1 Like

Thank you so much @Pau1 and @Diztraido2 , I faced the same problem when installing iOS and Android packages in Unity 2017.2.0f3. You guys saved me!

This solution worked for me. Thank you.

My file system is already set like that, and still can't install the build support..

That's it for me, I have 2 version of Unity and I renamed it....

Had the same problem with 2017.3.1f1 installed through the Unity Hub.

Hub places the files into /Unity/Hub/Editor/2017.3.1f1. So I had to move the files to /Unity/ and install the module. Afterwards copy the files back to the original folder and it works like a charm now.

Thanks folks. :)

1 Like

I had the same problem and was able to fix it following @quicksly_1 method. Thanks!

I simply temporarily renamed the folder version I want to use "Unity" and the module installed correctly. Then renamed the folder back with the version number.

is this really the current solution with the Hub?!

Hi..

unity 3d how to check app installed in ios device code

Thanks!

@Chintan-Kansagara Can you elaborate? Are you asking if a particular Unity game is installed on your iPhone?

I can't believe that was necessary, but yep, that definitely worked. Running 2017.4.10f1 and I successfully got the iOS build support module installed.

If you try to install build support from inside Build Settings, it fails. But using Unity Hub's "Add Component" feature works. Go to Installs tab, find your installed Unity version, click ..., select "Add Component".

5 Likes


The same for me. I had to move Unity.app to Unity folder for a time and after install move back to Editor folder.

wow this still isn't fixed - I had to move my Unity.app into my Unity folder in my Applications to install the IOS module too