Can't install Unity engine (0xc0000005)

I got my new PC and I wanted to install Unity engine (5.3.5.f1) to practice for my college course. I started installing it and everything was going fine. After Visual Studio got installed it asked me to restart my PC, so I did. After restarting nothing but Unity and IE6 was working. The same message appeared everytime I tried to use anything. “The application was unable to start correctly (0xc0000005). Click OK to close the application.” Not even cmd.exe worked. So I used system restore to get everything working again, used sfc /scannow to check for corrupt registry files and tried to install unity again. With no success as the same thing happened.
Specs
Windows 7 64bit
8GB RAM
Gtx 960
i-5 3340
DirectX 11

Try to boot in safe mode. Before “Starting Windows” logo BUT after the manufacter logo press F8. Then, select “Safe Mode with command line” (not sure how it’s called in English) and try to run it there and also run these commands:

wusa.exe /uninstall /kb:2859537

wusa.exe /uninstall /kb:2872339

wusa.exe /uninstall /kb:2882822

wusa.exe /uninstall /kb:971033

After each one is executed, reboot.

Another way is to open С:\Windows\SoftwareDistribution\Download in Explorer (hope this one works for you) and delete everything that is possible. Then, boot in safe mode and restore to the earlier restore point if any.

There are two other reasons: somehow RAM broke (test it using MemTest86, if it fails, then RAM has to be replaced) or drivers did (find a way how to reinstall them).

If nothing works, it’s easy to perform clean Windows reinstall.

(Google helped me a lot)