Can't install visionOS Build Support module on Windows?

When I try to install the visionOS Build Support module for Unity 2022.3.21f1 via Unity Hub on my Windows PC, I get a “Download failed: Validation Failed” error.
Unity_Hub_wBZwcGlwcV

Does this mean that one cannot install the visionOS Build Support module on windows at all?

For teams that are working on a mix of Mac machines and Windows PCs, if the Windows PC folks can’t install visionOS, then I’m not sure how we can have the Windows folks working in the Unity project.

Looking at the UnityHub log, the corresponding lines seem to be:

{"timestamp":"2024-03-07T18:27:46.895Z","level":"info","moduleName":"Disk Validation Strategy","message":"[ 'Executing the Download Validation Strategy...' ]"}
{"timestamp":"2024-03-07T18:27:46.896Z","level":"info","moduleName":"Disk Validation Strategy","message":"[ 'Validating destination path permission for access...' ]"}
{"timestamp":"2024-03-07T18:27:46.897Z","level":"info","moduleName":"Disk Validation Strategy","message":"[ 'Destination Path check: Passed' ]"}
{"timestamp":"2024-03-07T18:27:46.897Z","level":"info","moduleName":"Disk Validation Strategy","message":"[ 'Validating source path (https://download.unity3d.com/download_unity/bf09ca542b87/TargetSupportInstaller/UnitySetup-VisionOS-Support-for-Editor-2022.3.21f1.exe) availability...' ]"}
{"timestamp":"2024-03-07T18:27:47.201Z","level":"error","moduleName":"Disk Validation Strategy","message":"[ \"Error occured in 'Source Availablity Check'. AxiosError: Request failed with status code 403\" ]"}
{"timestamp":"2024-03-07T18:27:47.201Z","level":"info","moduleName":"Disk Validation Strategy","message":"[ 'Source Availability check: Failed' ]"}
1 Like

We don’t manage Hub, but I am asking internally with that team to see what might be up.

1 Like

Today, when I tried to replicate the issue, I no longer see visionOS Build Support in the list of possible Platforms in Unity Hub.

It seems like visionOS Build Support was never meant to be installed on a Windows PC.

yup…

https://docs.unity3d.com/Packages/com.unity.polyspatial.visionos@0.1/manual/Requirements.html

Even though you can’t install the visionOS Build Support module on a Windows PC, you can still open a Unity project that includes the PolySpatial packages. This does limit how much active development that one can do on a Windows PC, but at least you can open the Unity project without errors and make changes.

PolySpatial is not the same visionOS build support. In previous versions, you could build Xcode projects for Windowed applications on Windows, but not MR or VR builds, those require PolySpatial.

Anyway, I am experiencing the same issue as OP. When can we expect a fix. This is regression…

This isn’t a regression, as we never supported visionOS on Windows at all before. It is unfortunate this is still broken and we are working on it.

This is false, visionOS build support was supported in 2022.3.19 for windowed applications. Please read my post next time. This is not discussing PolySpatial. OP’s link even points to:

{"timestamp":"2024-03-07T18:27:46.897Z","level":"info","moduleName":"Disk Validation Strategy","message":"[ 'Validating source path (https://download.unity3d.com/download_unity/bf09ca542b87/TargetSupportInstaller/UnitySetup-VisionOS-Support-for-Editor-2022.3.21f1.exe) availability...' ]"}

“UnitySetup-VisionOS-Support-for-Editor-2022.3.21f1.exe” exists, it’s just a dead link that Unity Hub is pointing to.

Retaining build support cross-platform OS crucial for mixed teams using Mac and Windows. Again, not talking PolySpatial, this is build support.

Note that visionOS support is listed for Windows here:

The link is dead, though. This is absolutely regression if you’re saying visionOS build support was dropped from Windows.
https://download.unity3d.com/download_unity/bf09ca542b87/TargetSupportInstaller/UnitySetup-VisionOS-Support-for-Editor-2022.3.21f1.exe

2 Likes
  • VisionOS: Added VisionOS as a target for Windows and Linux. (UUM-63466)
    The changelog states that the windows version of visionOS plantform is supported, so this should be a bug with a download link

It is and the appropriate internal team is on notice and looking to have it resolved soon.

3 Likes

This should be resolved now for 2022.3.21f1 and 2022.3.22f1.

I can download now, but install failed.

Update:
I succeeded intall “visionOS Build Support” Component Installers without UnityHub.

https://download.unity3d.com/download_unity/887be4894c44/TargetSupportInstaller/UnitySetup-VisionOS-Support-for-Editor-2022.3.22f1.exe

3 Likes

Yeah, I see the same thing. The Hub team is looking into it but for now the direct download link should work.

1 Like

I do apologize for the confusion and issues around this.

1 Like

Checking in on this, it still happens with the 2022.3.23f1 version as well
image

I believe this should be fixed now. Can you try again?

Just tried again **
image
**

I’m getting the same error
image

This method works.