Can't Login to Unity Hub

Hello,
i’am updated the Unity Hub to 3.1.1, now i can’t login to my account to get assets from the store.

Its on 64x Windows 10.

What i tested:

  • Restart PC
  • Disable Firewall
  • Disable Antivirus
  • Delete Cache and Appdata Files from UnityHub
  • Reinstall UnityHub
  • Start as Administrator
  • Wait 30 Minutes after clicking Login Button

It’s still not working.

This is how it looking right now:

If i click “Sign In” or “Create Account” it does nothing.

1 Like

#Bump

Problem is still there, that makes me unable to make process…

Can’t find a download to downgrade Unity Hub.

1 Like

Hi sorry for my english i'm french.
need help too, my hub do exactly the same, can't even sign in one time can any dev or mod help for it please ?

1 Like

I have the same issue using 64x windows 10. Clicking either the Sign In button or the create account link does nothing. I tried restarting the computer, uninstalling and reinstalling and also restarting the computer again but it still has the same problem. I haven't been able to find anyone with answers as of yet.

1 Like

I am having the same issue

Same issue, installed on a laptop because i am on the move, the link the hub get's is not valid, and opens a browser then the editor and says "Something went wrong. Please sign in again."

So i guess i will write a small BAT script that will just "try again" over and over..

The link the hub gives me does not work, here is the link.

https://api.unity.com/v1/oauth2/authorize?client_id=unity_hub&response_type=code&code_challenge=kFYUF9aDAfSbWr0Lm6OSfzdaHn3d_-gc2EkoY6T2eok&code_challenge_method=s256&redirect_uri=unityhub%3A%2F%2Flogin&locale=en_US

Looking into the API, it actually responds with

Query parameter is invalid. code_challenge is too short

FIXED IT!

By reinstalling Microsoft Edge, because the Login Link gets open with that, instead of default browser..

1 Like