Can't open any projects: Shader compiler initialization error :Failed to read D3Dcompiler_47.DLL

Hello, yesterday I downloaded a project from a repository that needed 2020.3.7f1 version, upon opneing the project, the following error arised:

184921-error2.png

I created a new project and the same happened when openning it. The versions 2020.3.16f1 and 2021.17.f1 also have the same issue.

I have tried reinstalling the version and updating Unity hub. I have DirectX installed, I also checked the System32 folder and the dll is there, plus it has reading permissions.

Is there any known fix that isn’t downgrading the version? Any help or possible fix would be appreciated…

2 Likes

Ok, I found a solution in my end:

The antivirus software I used (360 Total Security) seemed to be locking the DLL from Unity version AT INSTALLATION, so even if you deactivate the antivirus, you can’t open projects, so you need yo deactivate / uninstall it, then install the version you need and that solves the problem.

Also 360 user here. I tried what you said and it worked. Thanks.


Menda ham shu narsa chiqyapti nima qilsam boladi​:pensive::pleading_face::thinking:"360 yoʻtal security" ni oʻchirib tashladim. Lekin ochmayapti Kompyuterim yaxshi, internet yaxshi, unity hubni versiyasi 3.5.0. Lekin baribir ochmayapti. Yordam uchun oldindan raxmat!