Can't see animations of model

In the “Animation” tab for my model, none of the animations show up. All I get is the warning:

“The rigs of the selected models are not setup to handle animation. Change the Animation Type in the rig tab an click Apply.”

It is a human model. And for “Configure Avatar” Unity recognizes it as T-posed. I have tried the 3 different “Animation Type” options, but the problem remains. The actual animations seem to be imported correctly as I can find them in the Project window, however I cannot edit them from there.

Here is a picture of what I am describing:
Unity inspector inspecting the model I am having issues with.

I do have the same problems for generic armatures too! I think I tried everything but I could not find any solution either. I guess this is a bug since it works perfectly fine for other models created exactly the same way.

This seems to be a bug in Unity 2018.3.0b8. I tried a new model which worked in 2018.2.14, but the same model did not work in the new beta. We will just have to wait for a fix.