Can't sign into Unity Hub - Sign in window is blank

I see that this has been a problem for a few years now and it seems that most people don’t find a solution. Still, maybe someone can help.

I’m trying to get Unity set up on a new computer, and it’s not going well. I’m unable to start Unity since it requires a license. In order to set up a license, I need to log in. In order to log in, I need to go through Unity Hub. When I try to log in via Unity Hub, I get a blank window. I’ve uninstalled and reinstalled several times.

Would love to find some way around this.

In case you or someone else’s still having this issue. Try doing this.

  1. Close Unity Hub, and also close it from System Tray.
  2. Open Task Manager, and kill all processes named Unity Hub (if there’s any, or proceed to next step)
  3. Press Windows Key + R, in the opened window, type %AppData% and hit Enter.
  4. An Explorer window will open; find and delete Unity Hub and UnityHub folders.
  5. Open Unity Hub and you’ll try to log in.

This worked for me.

I had the same problem, yet it was both blank and the window was around 0.5cm high. Your solution worked for me, thanks a lot @Donnald_Johnson



After looking through the logs I found that Unity Hub could not find my Windows Product key in the registry as the String was blank. After entering the product key in the registry I was able to sign in.

Checking the log file AppData\Roaming\UnityHub\logs\info-log.json I found the below entry which highlights “Key Not Found”

{“moduleName”:“App”,“level”:“error”,“message”:“[ ‘Failed to start Unity Hub, reason: Key Not Found’ ]”,“timestamp”:“2019-05-19T10:44:37.039Z”}

To fix this do the following:

Open regedit and goto Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion and enter in your windows product key XXXXX-XXXXX-XXXXX-XXXXX-XXXXX in the ProcudtID feild. Once entered make sure to kill all UnityHub processes and reopen Unity Hub.

bump - same issue Hub version 3.3.0