Can't type anything in inspector

I can’t type or select any text field in the inspector. q w e r t y keys select selection type (move, rotate, etc) instead of typing.

Probably a dumb question but I have googled and searched extensively and can’t find a whiff of a solution.

I assume I have entered some kind of special hotkey mode. Typing works fine in other programs. Don’t have scroll lock or anything enabled.

Same problem here. Easy work around that works for me (haven’t restarted the program yet) is:

  1. Move out the Game tab to another desktop (on another monitor in my case)
  2. Simply click anywhere in that Game tab screen (where the game usually plays)
  3. Now come back to the Inspector in the editor and typing now works

FYI: Clicking and dragging on the label to change number values still works for some reason even when there is no ability to type, e.g. in the Rect Transform, if you mouse click and hold on e.g. Pos X and then drag in left or right direction.

I have the same issue. It worked a few weeks ago but then the problem appeared out of the blue. There is a workaround that works for me.

  1. Go to the Asset store tab.
    1b Click in the search bar but do not type anything.
  2. Click the Game view tab.
    2b Click somewhere in the game view but not on any game object (click somewhere on the skybox or something)
  3. Click on the Asset store tab again but do not click anywhere else.
    3b Start typing. Yay, you did it!
    I think it’s because Unity won’t stop listening for shortcut commands when you go from the Scene view to the asset store tab. But If you go to the Game view and click in it Unity will stop listening for shortcut commands.

Well, still no idea what the cause was but fixed the problem by reinstalling. Now 5.4.03f

Edit: Actually:
Had to go back to 5.3 versions because 5.4 broke everything. When I reinstalled 5.3 I had the same problem again. Seems like a bug.

If you made a backup then close Unity, delete all .meta files then open Unity.
It won’t work the first time, but when you open it again it will work.

Tip: go to the folder of your project and type in search “ext:meta” no quotation marks. It will find all meta files.

This just happened to me…

In my case it was the keyboard drivers / lack of. I have a logitech gaming keyboard. But I did not install the software. I just let the generic drivers do their thing. Anyways, I put in the logitech software, and I assume drivers, and it worked.

I just grab the game window tab and pull it out from wherever it is docked and put it back. Then I get my inspector cursor back.