Cant use monodevelop anymore

Hi all, I’ve been using unity 5.1.2f for a long time without any internet. One day I decided to update to latest version 5.4.x. Monodevelop, convert to windows line ending or keep it unix, this question appeared when I open my script. I choosed both convert and keep. But there is still error on using unityengine and system collection. those lines turn red. And with no autofix or even suggestion. Help me pls how to use the latest version or I have to use 5.1 forever?

go to edit->preferences->external tools and select monodevelop and also always convert line endings.