Caret missing in InputField on iOS and Android

I have multiple InputFields and I expect there to be a blinking caret to indicate that a particular InputField is selected.

The blinking caret is there when running the app on the Unity editor but on Android and iOS it is missing and it can be quite confusing for the user. I don’t see an option to enable it. How do I get it to show?

The caret won’t show if the caret width is too small. Select the InputField in the Hierarchy, look in the InputField (Script) component in the Inspector, find Caret Width, and change from the default of 1 to a larger value, such as 3 or 4.

Also make sure Hide Mobile Input is unchecked. That option is 3 fields below the Caret Width setting in the Inspector.


@jeff-smith thank you so so much, on the PC by having the Oculus connected via Quest Link everything worked, but not in the Oculus itself, by unchecking the mobile box the problem is solved, the caret is visible