Cascade shadows leave black lines effect on grass

I am building a scene with a lot off terrain grass. The only way for me to get shadows on the terrain is to turn on cascade shadows (im using 4). It is working fine, however the crass gets black at the points of cascades. You can see a black circle on grass on the screenshot. How can I fix that?


This took a lot of patience and tweaking.


minimum editor version 2019.3.2f1
window > package manager > expand Universal RP > select 7.4.1 > update to 7.4.1

minimum editor version 2020.1.0b87.4.1
window > package manager > expand Universal RP > select 8.1.0 > update to 8.1.0

This will fix the default unity terrain detail renderer. I was using GPUInstancer in my project, which I had to disable as it had the same issue despite the updates.


This was killing me too but i just figured it out!

Go in to your Terrain editor, like you’re going to add more grass…

Hit the little gear icon to open “Terrain Settings”.

Make sure “Cast Shadows” is set to off.
( should be about the 8th setting down in the menu)