(Case 1336903) Exporting a package is broken

Using 2021.2.0a17 I wanted to export a very small package containing two scripts. Normally the operation should be instantaneous but nothing happened; Unity froze and I had to kill its process in the task manager.

in my project directory, in the "Temp" folder I found another directory named "Export Package" containing another folder named by a series of numbers, itself containing an "asset.meta" file.

Opened in a text editor the "asset.meta" file reads:

fileFormatVersion: 2
guid: 2719456758e79395081b451df67840e4
folderAsset: yes
DefaultImporter:
  externalObjects: {}
  userData:
  assetBundleName:
  assetBundleVariant:

And there was a warning in the console but I couldn't access the console, Unity being frozen, I just got what the editor showed at the bottom of the screen:

7143755--854690--Capture d’écran_2021-05-15_18-07-30.jpg

Updating the thread with case number: 1336903.

@LeonhardP

Here we go, my bug reports are rejected again because I'm not using the "right" Linux distribution:

[quote]
Hello,
Thank you for reaching out to us.
Unfortunately, we do not officially support the Mint Linux distribution, only the following ones are:

Ubuntu 20.04
Ubuntu 18.04
CentOS 7
You can check the supported Linux configurations here: https://docs.unity3d.com/2021.1/Documentation/Manual/system-requirements.html
I also noticed that the project is created on Samsung T1 SSD (found the path used to open the project). You could try to create a new project on an internal SSD or HDD drive to see whether it solves the issue.
I will now be closing this case. If you have any further questions, feel free to reply to this email and the ticket will be automatically re-opened.
Best wishes,
xxx
Customer QA Team
[/quote]

Not counting the *** recommendation at the end of it...

I suppose all the others will be rejected too. What's the use then?

Edit: apparently, the bug was tested under Ubuntu and wasn't reproduced. That's what the qa team should've said in the first place instead of slamming the "you don't use the right Linux" door at my face.

Apologies for the confusion. The team is generally trying to reproduce reported issues for Linux on supported distros, even if the reports originate from unsupported distros. In this case, the issue wasn’t reproducible and thus closed.

What’s wrong with the recommendation?

1 Like


Exporting a package is broken only in 2021.2.0a17 and a few previous alpha versions and all my projects are created on the external SSD mentioned.

To make things clearer (I hope):

  • Linux is installed on an external SSD,
  • this external SSD has two partitions,
  • on one of them the editors are installed,
  • on the other the projects are installed.

I've never had any problems with that organisation.

Now I'm waiting for a20 (since a18 and a19 have been cancelled) to see if this happens in that version too.

In the meantime, I tried exporting a package a last time in 2021.2.0a17. I created a new project, added a script, for good measure, and launched the process. 40 minutes later, still no package. The last line of the log is that one:

Start ondemand import (priority Urgent): Assets/Scenes (Guid(8aae9321f5eb4f80db485559185a154b) Importer(815301076,1909f56bfc062723c751e8b465ee728b))

Ha ha! Fixed in 0a19! :smile:

1 Like

It's also happening in Unity 6.0.8, using Windows 11.
After compressing the package, it throws a message with "there is less than 1GB in disk", however there is still 170GB left in the disk where the project is, and 350GB in the disk where I wanted to export the package.
Don't know if I all of the process was wasted and I have to delete the Temp folder or if I can do something to continue the process.