(Case 1369722) Jagged shadows in Android platform

Hi. I found that shadows in Android platform is extremely jagged. It does not with URP 11. Only URP 12 has shadow issue.

This is easily reproducible. Create URP default project, and change platform to Android then see shadows in SampleScene.

Reported as Case 1369722.

https://issuetracker.unity3d.com/issues/urp-android-jagged-shadows-when-switching-to-android-platform-in-build-settings

1 Like

I'm experiencing this on both Android and iOS. Enabling/disabling soft shadows doesn't seem to have any effect.

[quote=“Kichang-Kim”, post:1, topic: 858351]
Hi. I found that shadows in Android platform is extremely jagged. It does not with URP 11. Only URP 12 has shadow issue.

This is easily reproducible. Create URP default project, and change platform to Android then see shadows in SampleScene.

Reported as Case 1369722.

https://issuetracker.unity3d.com/issues/urp-android-jagged-shadows-when-switching-to-android-platform-in-build-settings
[/quote]

I’ve been struggling with this problem for a long time and found where the bug is. Apparently, the light map compression algorithms on Androind are horrible. Disable the compression and the results will be much better.
Hopefully, this bug will be fixed soon. I will see it on Unity 2021.3.4f1 URP12.1.7