case796074:Stereoscopic rendering Worked in Unity 5.3.2 but new Stereo Display (Flat Screen) doesn't

Reposting my case report to the forum if see if anyone else has work arounds.

Stereo Worked in Unity 5.3.2 but stopped in 5.4+ betas. The stereo as "Stereo Display (non head-mounted)" doesn't work at all.

A simple test of a scene with two cameras, Left and Right set to render to left and right eyes doesn't work any more.

Build the project and run on a stereo enabled display that uses DIN active shutter glasses. The application shows no image. Even on a non stereo display, the application shows no image.

Something very wrong is happening. The old method where you would check "Enable Stereoscopic rendering" worked. But the new method doesn't. I have tried messing around with the api and various orders in which to enable stereo but nothing works.

5.3 stereo applications work. And the DX11 stereo application works too.

What am i doing wrong? Also is there an example of a stero 5.4 app that works with stereo. I have a quadro card and DIN style stereo syncroniziation of Active shutter glasses

Maybe not much (not any) Help I've the same problem (and same hardware) but try to put another Graphics API (OpenGLCore and Direct3D11 )

christian

DX11 works in 5.3.2 amazingly works in active stereo in windowed mode. 5.3.2 is missing some features that i am very excited are included in the betas. (scripting access to stereo camera parameters)

Neither Direct3D11 nor OpenGL core work for me in the betas.

It is understandable that it's not working in the betas, but it is very import for me to have this working in the next public release. We have all of the esoteric active stereo setups needed to do the tests, so that's why im hoping we can get this sorted out in these incremental beta releases.

I have the exact same problem here too. I'm running more tests, but so far no luck. Even though all my cameras return a stereoEnabled flag to true, and VRSettings are enabled, I keep getting a pure black screen rendering, and 3D mode is not triggered.

Any help much appreciated.

Can we get a bug report ASAP? This sounds like a major regression.

Submitted as case 802531. Thanks !

Thanks. Reproduced it and forwarded to the right people to look at it.

Thanks ! crossing fingers ! :)

Hey I'm wondering, since this issue is still there in 5.4.0b22, is there any plan to fix it ?
My report on this issue has been closed without any info (https://fogbugz.unity3d.com/default.asp?802531_5rfgp7btb9ekvabk).

It has been fixed, though I don't think it made into a build yet:

https://issuetracker.unity3d.com/issues/vr-stereo-worke-in-unity-5-dot-3-2-but-stopped-in-5-dot-4-plus-betas-the-stereo-as-stereo-display-non-head-mounted-doesnt-work-at-all

Thanks for the good news !