Changing from PC to Android platform hangs indefinitely, Unity 5 only.

I have a Unity 5.3.5f1 project. When I try to switch platforms from PC to Android, a status bar appears that says “Calculating asset hashes…”, the bar fills to either 0%, 25%, or 75%, and then hangs there indefinitely. I’ve let it sit here in this state for up to 20 minutes or so before force-quitting Unity to try again.

I don’t experience this problem on Unity 4.7.2. I have a different project there that - when changing from PC to Android - brings up a popup box that shows it converting individual named assets. Once the asset processing is finished, the platform change completes as expected.

I am running Windows 10. I have already installed the Android SDK and NDK (r10e) and added their paths to both the External Tools menu and the Windows path system variable.

Anyone have any hints or tips that might help? There are certain tools my project uses which run only in the mobile platform environment, so I’m a bit stuck until I can get over this hump. Thanks!

Additional notes:

  • I’ve tried running Unity as an administrator in case any of the asset conversion steps secretly required it. No dice.
  • I have the texture compression settings drop-down for Android set to “Don’t override”.

Mavina’s suggestion has solved the problem. Thanks for the tip!

After I deleted the Library directory and restarted the Unity Editor, it began rebuilding Library. It then complained about a particular asset file: A symlink. Apparently, Unity on Windows doesn’t know what to make of these. Thankfully the symlink is no longer needed in the project so I was able to remove it. Deleting the symlink allowed Library to finish rebuilding, and I can now switch platforms just fine. The symlink may be what was causing the platform-switch lock up in the first place.