Changing scene messes up lights

I currently have two scenes in the project, and whenever I switch between them, the lights messes up.
The first scene that loads is fine, but the second has its directional lights dimmed, the third has all lights dimmed and the fourth have no light at all.

It doesn’t matter if I load the other scene or the same that just played.

I don’t know what is causing it. I have tried the global light settings, I have checked that no script is changing any lights, I have tried overriding the light settings manually, it just won’t work.

The scene change is triggered through JavaScript when the player touches a “goal” object.
The script looks like this:

#pragma strict

function Update () {
	transform.Rotate(1*(Time.deltaTime*10), 0,0);
}

function OnCollisionEnter(col : Collision){
	if(Application.levelCount-1 > Application.loadedLevel)
		Application.LoadLevel(Application.loadedLevel+1);
	if(Application.levelCount-1 == Application.loadedLevel)
		Application.LoadLevel(0);
		
	Physics.gravity = new Vector3(0, -9.81, 0);
}

I have tried removing all other scripts and just have the player drop right onto the object, that gives the exact same result, so I don’t think any other scripts are messing with it.

It’s due to the global Illumination. Try to uncheck every GI stuff, especially the “Continuous Baking” on the very bottom of the menu.
Note that this “bug” only happen in Editor, you build will be fine.

Eventually I did get it to work. What exactly the issue was, I do not know, but I worked it out by creating my own skybox material, implementing it, turning off GI Baking and Continuous Baking and baked the GI manually.

I had the same problem heres a fix:

  1. Before launching ur scene make sure the light isn’t bugged!

  2. If it’s not bugged and it’s becoming totally black then try to add other kind of lights

  3. If it is bugged try to reposition it or/and readd it in your scene!

Hope you fix it!!
~carlqwe

Try copying all lighting settings and make sure to assign your baked Lighting Data Asset (at lightmaps tab) in the loading scene - and any intermediate scenes - , that worked for me.

I ended up making a new scene and importing all my stuff from the broken scene by making them prefabs. Just had to reconnect a lot of variables, but fortunately it was a small-ish scene.

I didn’t actually manage to fix it properly inside the same scene, but I couldn’t really find any settings that were wrong. I think the scene was damaged at some point, it’s meta file created problems at the start if I remember correctly. (was using Unity 2017.1)

I’m a newbie and none of the advice helped me. However when I went to Window > Rendering > Lightning > scene tab; If “lightning setting” says “none”, click on it and choose “demo”- setting. Press “generate”.
So it seems like it was missing settings all together which made the scene go dark when loaded. Hope this helps.