Changing thickness of plane collider in default plane...

It looks like the thickness of the default plane’s collider actually changes with the plane when you scale it to a larger size!! Is there a way to change the thickness?

alt text

The thickness does not change on the default plane collider–it’s a 1-sided mesh collider and it’s mathematically impossible for it to have any thickness. You can always replace any collider with whatever you want, such as a box collider, if you want it to have thickness. Conversely, if you don’t want any thickness, then a mesh collider using the default plane mesh will provide that.

Turn off the “Convex” option in the mesh collider. The calculations are being screwed up when you tell it to be convex.