Character Controller not moving model at all, but acts like it is?

SO, my hierarchy for my object.

\ Unit (contains capsule collider *trigger* and character controller)
|__\ Model
   |__\ geo
   |__\ geo
   |__\ geo
   |__\ geo
   |__\ geo

I am using character collider on the root of this object, Unit. My movement is for sure working. It was working before on a simple object like a collider, but when I throw in actual models it doesn’t work.

I do some basic movement like

Vector3 movement = _move_direction * speed + new Vector3(0, _vertical_speed, 0);
movement *= Time.deltaTime;
_unit_focus_cc.Move(movement);

_unit_focus_cc is something I am dynamically change to move different objects using one character controller. I have tried this before and it works so this is not my concern.

Using character controller Move method doesn’t work, but when I do something like …

Vector3 pos = _unit_focus_cc.transform.localPosition;
pos += (_unit_focus_cc.transform.forward * 0.5f);
_unit_focus_cc.gameObject.transform.localPosition = pos;

I have two triggers, but remove the capsule collider still doesn’t help me move the character and it shouldn’t affect it since it is used only for triggers.

Hoping someone can help me understand why my object isn’t moving.

Ok, found the problem. The models had colliders for each geometry imported, so that was pretty much it.