Character falls thru to his waist

I have followed the Mecanim tutorial thru and now Im trying to get my own character into the system. Im falling at the first fence!
After setting up the avatar, and adding capule collider and rigid body, I tweaked the cap collider to fit and hit play, and he fell thru to his waist. As you can see from the picture there appeasrs to be some default anim connected, even tho I haven’t got that far yet. The character is a Mixamo thing, and as such has a greyed out anim there by default.
Could this be causing it?
How can I stop this?
looks ok?
In the mud

Ahoy, Mark! Not sure if you’re still having this problem, but I think I can be of some assistance!

You may notice at run-time that you get a yellow error in the log regarding the particular animation file you’re trying to play. It mentions that you have a generic animation, but you’re trying to apply it to a humanoid rig, so it discards it. (It seems to stick the character in the muscle test pose when it has nothing else to go on, which is what you’re seeing in screenshot numero dos)

To Fix this:

1.Select your animation FBX files, and click on the rig tab in the inspector.

2.Change “Animation Type” to “Humanoid”.

3.Change “Avatar Definition” to “Copy from Other Avatar”.

4.Now in the “Source” field, choose the Avatar file linked to your In-world character.

5.Press apply!

I hope that does the trick for you, I know I had to spend some time digging around to figure it out when it first happened to me. Let me know if you’re problem is resolved, it’d be nice to be able to contribute to a solution once, I spend most of my time asking questions :stuck_out_tongue:

John S, Tech Animator

This is a super old thread, but I want to mention what the actual cause is… The Avatar your animations are referencing is not the same avatar as currently being used. They were set up with a different rig at some point and thus cannot place the pivot of the model in the appropriate place.

TL;DR make sure you are using the exact rig with the animations.

Make sure in each clip of your animations (Inspector tab) that your ROOT TRANSFORMATION POSITION (Y) is set “Based Upon - FEET”! If the Inspector tab is grayed out then click on EDIT right below the cog wheel in the inspector tab at the top right. Make sure to click apply when you make changes, found at the bottom of the same window scroll down. (Only if it was all grayed out, there will be no apply button if it wasn’t grayed out.)
Also make sure bake into pose is checked.
Then while having the scene run use the scene view to look at the distance of the players feet from the ground. While doing that use the offset from root transformation position (Y) OFFSET to change how high from the ground your players feet are… THIS FIXED ALL OF MY ISSUES… Don’t worry about all the avatar stuff if it didn’t work for you (As non of it worked for me)

Hey John!

Thanks so much for your suggestion, Ill check when I Get to work.
In definately missing something when it comes to mechanim. I can see its use as a cool way to blend. But dont understand how its a replacement for animation generally.
On this point, Do you know if its possible to use LOOSE anim clips, as In ones that Are NOT embedded In a FBX? I have a good collection of motions for My character In the legacy system, but they are not attatched to meshes.

As a non coder, I am struggling too with the Control script, only having the BotControl script from the original tutorial for mechanim.
Im hoping to rebuild this In PlayMaker soon, so I can implement MY needs. as that tutorial has picked a very strange method.

cheers for your help


Hi Mark,
I’ve a similar problem.
I’ve a charater animated by mecanim that should fall using ragdoll (so I’ve to deactivate mecanim during the fall). When the character impacts with ground, it works fine, but when animator is disabled completely, the character falls in the ground till his weist, like in your pics.

I was facing the same issue, hope this helps:

This is old, yes. But in the interest of other people with the same question, here is a quick fix that worked for me and I suppose could easily be overlooked.

Try changing the animation’s “Scale Factor” in the import inspector’s “Model” tab to 10 or 100.

As far as I can tell, it is very likely related to a common problem with the programs that use FBX (notably, Maya), where they misscale the model 10 or even 100 times. Since there is no geometry in the animation and scale doesn’t affect the bones, Unity’s import parameters can fix the pivot point’s position without messing anything else up.

I was having the same issue. After messing with the scale in my 3D package (Maya), I found that exporting when my scene scale (preferences/settings) was set to meters - caused this issue (applying “Humanoid” Rig in Unity made character drop and center on his waist).
Then I set my Maya scene to centimeters (in other words, .01 meters) and Unity Humanoid rigging sets my character centered at the feet, like a charm!
Countless “moderators” have said scale is not a factor. Not true.
Hope it helps.

I was facing the same issue and managed to figure it out, When I imported my fbx file with the animations into unity, I scaled the model to scale 5, but I did not scale the Animation objects that I also imported into Unity as well, thus the animation was smaller than the size of the model, If I then played the animation, my character fell halfway through the terrain, so just scale your animations to the exact same size as the original model and you will not have any more problems since the animation and the models will be 1:1 ratio, Good Luck!

make sure that the rig type (“animation type” in inspector) of all of your animations and character are the same.
then, make sure that any animations that have “copy from other avatar” have the correct avatar dragged into the “Source” field. and that the character itself has “create from this model”

Show this video very easy to Character Animation with Mixamo