Character mesh breaks when build

the character look like this when running in the editor.

that looks good.
but when i build my project, this happens

the textures gets all messed up, and the geometry get meshed up as well.
does anyone reconize this? or know how to fix this?

I too am having a very similar problem. I did see a forum post somewhere where they suggested that it was the number of bones used setting in the Quality settings (range 1 to 4), but my build was already set to use four bones.

Perhaps it’s possible that we’re using character meshes that need more than four bone’s influence on parts of the mesh? (I’m experimenting with animating Daz3D characters)

If anyone has any insight, would be greatly appreciated!

bumping this if there was a solution - I’m having the same problem.

Took me ages to solve this problem, learnt a lot in the process. Solution 3 was the one that finally worked for me.

Solution 1: Your bone quality is set to low in the project settings

Edit → Projects Settings → Quality → Skin Weights and select ‘Four Bones’ or ‘Unlimited’

Solution 2: The bone quality on your actual mesh is too low

Select your mesh → Go to the Skinned Mesh Renderer → Quality and select ‘Four Bones’

Solution 3: The game is being built at a lower quality level regardless of the Skin Weights you select

Edit → Projects Settings → Quality and remove all the levels that don’t say ‘Fantastic’ using the ‘trash can’ button.

If you’re still having problems someone mentioned this occurred when they had an error in the build which prevented unity from applying the right quality settings on build.

I have the same problem and i fixed it. Go to Project settings/Quality and in top of the list you find Quality levels. In Default parameter select higher level then you already use(for build platform).