Character Motor Collision

Problem: Collision doesn't slide off objects well...too sticky

New Scene...
GameObject: Create Other: Plane
GameObject: Create Other: Cube
Drag in First Person Controller Prefab From Standard Assets (herinafter 1st PC)

Reset all positions to 0,0,0
Scale up the Plane (5,1,5) and Cube (5,5,5) 
Move Cube up (Y=2.5) and 1st PC up (Y=1.05) to be proper level with the Plane
Move 1st PC Z=-20 and rotate Cube Y=30
Expand 1st PC and select Main Camera within that, set position Y=2 and Z=-5

Change 1st PC > Character Motor > Movement > Max Forward Speed = 30
Disable 1st PC Mouse Look Script (not relevant to the problem)

Run in game view and hold arrow-up to race the capsule into the angled side of the cube

Observe that movement speed is reduced to a crawl as capsule -slowly- slides along the face of the Cube...speed was fast before and resumes to fast after it clears the Cube.

Is this because they have default physics materials on them? If you want something to slide then you need to create a physicMaterial with friction set to 0 or something very low. and also set frictionCombine to Min instead of average as it is be default.