Chrome blocking Unity

Chrome 42 now gives this error:

Sorry, Chrome can’t run this app
You are using a version of Chrome that does not currently support the Unity Web Player plugin needed to run this app.
We recommend using another browser, such as Firefox, Safari.
Alternatively, you can enable NPAPI plugins at chrome://flags/#enable-npapi (requires browser relaunch).

If you enabled the NPAPI flag and the plugin still does not work for you, try manual install.

Does that mean that Unity os now useless for web game development?

Not at all. The web player can still run on Chrome, but requires some technical work from end users. It’s very likely that end users will not know how to re-enable NPAPI plugins, despite the message being given in the browser. Unity is hard at work on a WebGL solution to allow developers to make games that run in browsers.

I use Chrome all the time! All I did was enable NPAPI then go to the webpage and in the top right corner in the URL bar there should be a red puzzle piece just click on it then click allow plugins on this website.

I can’t even get this working on my machine. I’ve enabled NPAPI and restarted the browser, re-installed the web player, but it still doesn’t work. I hope nobody thinks our end users will even get this far if even us developers cant run the app!! Great that webgl solves this, but only if I spend more time on redevelopment and distribution on already published app!!

I didn’t realize that all webplayer games would go into self destruct mode this year.