Clicking wav loops

Here's another question about those darn audio loops!

For some reason I just can't get my loops to work without clicking at the loop point. I've tried both wav and ogg formats, cutting them to zero-crossings and also the method where you cut off the begining of the file, put in at the end and make a crossfade between the two parts.

I'm using Cubase 5 to make the soundfiles. I've also tried to use loopopints to avoid the problem. For that purpose I used Wavosaur.

There is no click before I export the audiofiles from Cubase. There's no click when I play them in Wavosaur, but as soon as I listen to them in Unity they click. We're using Unity 2.6.1f3

Any ideas to what I should try? I have tried both mono and stereo versions of the loops without any difference.

This is strange, I've certainly had click-free loops before, for looped engine sounds, etc. And to achieve it all I did was follow the same steps that you've described (both the zero-crossing method, and the crossfade-end method).

Definitely export as wav, to your Assets folder. Perhaps you could upload one of the problematic wav files for us to try - to see whether the problem lies in something specific to your system or in the wav file itself?