Cloth stops working

Hey All,
I am working on a character, and i use cloth physics for the hair. It works pretty well. But lots of times the physics just stop. When i hit the play button again it works again, for some time. Sometimes it goes 5 minutes with not problem. And sometimes it just stops after 3 sec. for like 200x in a row. I don’t get it. Has anyone ever had this problem?

Im having the same issue. I thought it was because I was using a weird custom mesh, but Ive tried it with just the straight “cloth” object from the “gameobject>create other” menu and it just does not work. The cloth seems to interact with the attachment collider for a few frames, then it just stops. I can move the collider and the cloth doesnt move with it (even though its a parent) and I can move the cloth and the gizmo moves, but the actual cloth mesh stays in place.

It’s bizarre because Ive used a cloth object in a seperate scene in this project and it seemed to work just fine. I don’t know what the issue could be, Ive tried fresh scenes and projects as well to no avail.

Adding a value on X or Y or Z of the Random Acceleration fixed this for me.