Colliders don't work

Guys I am making a game in unity 5 in which there is a cylinder object and you have to roll it to a point to win.
I have a maze - like map and I used the built-in 1st person character controller.
The problem is that my player can see through walls when I go near them. Tried to make the collider bigger on the 1st person character controller, but I didn’t find any. I added it manually (capsule collider of course) but still - no effect. I made it very big to see if it works - it doesn’t while the other objects work properly. The “Is trigger” checkbox is unchecked.
My sphere doesn’t collide with anything except the floor of the map (it doesn’t go through the walls but still I can see through them). If you want any extra info ask in comments!
If you want I can make a video and upload it to youtube so you can see what is the problem.

Select your camera and go to the near clipping planes setting and reduce it to something like 0.001. What happened is the camera by default doesn’t start rendering anything for 0.3 meters (by default) away from the origin point. This means that if your viewing frustum is pointing through a wall anything closer then 0.3 meters to the cameras position will not be rendered resulting in the problem you are experiencing. Hope this helped. Ps if your camera is still inside the capsule mesh that’s attached to the fps controller by default reducing the near clipping point too much might cause it to show up as a strange looking graphical error. To avoid this either raise the camera so it’s no longer inside the mesh or place the mesh on a layer and tell the camera not to render it.