Color.clear and mesh are black not invisible

Like above i use Color.clear and mesh are black not invisible, i want mesh to be invisible.

i get back RGBA(0.000, 0.000, 0.000, 0.000) in debugger so it’s RGBA

To manipulate color from script i use:

GetComponentInChildren<MeshRenderer>().material.SetColor("_Color", Color.clear);

this is my shader code:

Shader "Custom/Strzalka" {
	Properties {
		_Color ("Color", Color) = (1,1,1,1)
		_MainTex ("Albedo (RGB)", 2D) = "white" {}
		_Glossiness ("Smoothness", Range(0,1)) = 0.5
		_Metallic ("Metallic", Range(0,1)) = 0.0
	}
	SubShader {
		Tags {"Queue" = "Overlay"} //Use many combinations here nothing work's
		ZTest Always 
		LOD 200

		CGPROGRAM
		// Physically based Standard lighting model, and enable shadows on all light types
		#pragma surface surf Standard fullforwardshadows

		// Use shader model 3.0 target, to get nicer looking lighting
		#pragma target 3.0

		sampler2D _MainTex;

		struct Input {
			float2 uv_MainTex;
		};

		half _Glossiness;
		half _Metallic;
		fixed4 _Color;

		void surf (Input IN, inout SurfaceOutputStandard o) {
			// Albedo comes from a texture tinted by color
			fixed4 c = tex2D (_MainTex, IN.uv_MainTex) * _Color;
			o.Albedo = c.rgb;
			// Metallic and smoothness come from slider variables
			o.Metallic = _Metallic;
			o.Smoothness = _Glossiness;
			o.Alpha = c.a;
		}
		ENDCG
	} 
	FallBack "Diffuse"
}

Looks like your _Color parameter is transparent, but your shader ignores transparency.

This may do the trick : Shader Help: Adding transparency to a shader. - Questions & Answers - Unity Discussions - See nomadic’s answer.

In case the link breaks or whatever, here’s what he says:

For anyone who is trying to Write a
Surface Shader with Semi-Transparency
take note of these lines:

I changed:

_MainTex ("Texture", 2D) = "white" {} 
Tags { "RenderType" = "Opaque" }

to:

_MainTex ("Color (RGB) Alpha (A)", 2D) = "white"
Tags { "Queue"="Transparent" "RenderType"="Transparent" }

Appended “alpha”:

#pragma surface surf Lambert alpha

Added this line after o.Albedo…

o.Alpha = tex2D (_MainTex, IN.uv_MainTex).a;

EDIT: In your case, it’s just a matter of changing line 15 for :

#pragma surface surf Standard fullforwardshadows alpha