compiler failed because compiler couldn't be executed

What does this mean and how to make it proper please help please tell me in the easy terms

Thank You!

Does that compiler file exist there?
Did this ever work and quit working?
Have you rebooted your PC?
You might try right-clicking and do a run as administrator since you installed to something other than the default location (a long shot.)
You might also try installing to the default folder or just re-installing to a folder that doesn’t have a ’ mark in it. The ’ mark can cause problems if a program wasn’t written correctly.

for me it was Norton Antivirus putting Mono in quarantine.

I’ve had Unity for less than 12 hours, but I was getting the same message in my console window as soon as I made a script. Poppis is right; it was Norton. I had to take MonoDevelope out of the quarantine.

Here is the link to Norton on how to do that:

Hi I’m new to Unity and programming in general.

I had this error the first time I tried installing and running Unity.

I googled and went through a lot of forum posts with similar issues but this hasn’t been solved yet.

So I now offer my solution, which worked for me, and hopefully would help the community.

The error seems to be produced when Unity encounters a directory/folder with a space inside in it. And even after you reinstall the program, the error persists, after it occurs once.

so here’s what I did:

  1. Uninstall Unity using Revo Uninstaller, you can use the uninstaller of your choice, given that it has a deep registry checker that allows you to remove any registry entry that Unity produced. This is important.

2)Once you have uninstalled Unity and deleted all the registry entries, restart your computer.

  1. Reinstall Unity at the top level of your drive, this is to make sure it doesn’t encounter any directories/folders that causes it to crash (i.e C:\Users\Admin’s PC.… or even the C:\Program Files (x86)

  2. When ever you create a project directory make sure there is any space in the directory name, (i.e. E:\Game Design.… should be E:\GameDesign…

I hope this helps :smiley:


Go and Prototype Some More!


Sometimes when you try to build a project you oversee the specific folder where it’s going to be build .I had the same error in my console but just fixed that by deleting an unnecessary exe file from a different game i was working upon and i accidentally build the project in another games folder so just look up for the exe file and its data(of the other project other than what you are working on)delete it from the project and you are good to go.