Compiler Failed

I keep getting this compiler error every time I run unity. It was happening in 2.6, so I decided to install 3, and it is still giving me these 2 compiler errors at start up.

Compilation failed because the compiler couldn't be executed!


Could not start compilationWin32Exception: ApplicationName='"C:/Users/user1/Desktop/Tyler's Stuff/Unity/Editor/Data/Mono\bin\mono.exe"', CommandLine='"C:/Users/user1/Desktop/Tyler's Stuff/Unity/Editor/Data/Mono\lib/mono/unity\smcs.exe" @Temp/UnityTempFile-80df6f864853a6343a359099d829c0da', CurrentDirectory='C:/Users/user1/Desktop/Tyler's Stuff/Unity3D Games/Unity 3 Testing/Assets/..' System.Diagnostics.Process.Start_noshell (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) System.Diagnostics.Process.Start_common (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) System.Diagnostics.Process.Start () (wrapper remoting-invoke-with-check) System.Diagnostics.Process:Start () UnityEditor.Utils.Program.Start () (at E:/BuildAgent/work/68355d6e5d19d587/Editor/Mono/Utils/Program.cs:35) UnityEditor.Scripting.Compilers.ScriptCompilerBase.StartCompiler (BuildTarget target, CompatibilityLevel compatibilityLevel, System.String compiler, System.Collections.Generic.List`1 arguments) (at E:/BuildAgent/work/68355d6e5d19d587/Editor/Mono/Scripting/Compilers/ScriptCompilerBase.cs:65) UnityEditor.Scripting.Compilers.CSharpCompiler.StartCompiler () (at E:/BuildAgent/work/68355d6e5d19d587/Editor/Mono/Scripting/Compilers/CSharpCompiler.cs:31) UnityEditor.Scripting.Compilers.ScriptCompilerBase.BeginCompiling () (at E:/BuildAgent/work/68355d6e5d19d587/Editor/Mono/Scripting/Compilers/ScriptCompilerBase.cs:37)

It's never given me this problem before.

Try uninstalling all versions of Unity and then re-installing.

It also looks like you've installed Unity on the desktop. You might want to try installing it in the usual program files folder instead.

I haven't encountered the problem myself, but I think it's definitely worth a shot to do a complete uninstall and then re-install. The paths to the compiler might have become messed up somehow.

I was getting the same error ("compiler couldn't be executed"). Reinstalling Unity didn't work, but regenerating some assets (e.g. terrain) and reimporting all assets did the trick.

We recently ran into this error code in version 4.6.3f1 as well, and we found a solution.

It was one of our artists’ Windows machine and his C:\ drive was at capacity, so he installed Unity on D:\ instead. He also installed Unity 5.0.0f4 on his D:, but that seemed to be working fine.

He found this post and reinstalled but still got this error. I suggested that he install it on C:\ instead. It works now.

TDLR; Could be an assumption somewhere about C:\ that’s been resolved in Unity 5.