Compiling in Xcode fails

My first question on this forum and I hope someone can help.


I have used Unity 2018.3.12f1 (64-bit) and created some apps for iPhone (using XCode) without any problems. When the new update (Unity 2019.1 with the hub) was released I waited 5 months before updating but last week I updated. I have installed and am now running Unity 2019.1.4f1 (64-bit). The apps are working fine in Unity. The build process from Unity to iOS runs also without errors. I use option “Run in Xcode as - Release” and “Compression Method - Default”.


But when I compile with Xcode (version 10.2.1) on my Mac I get a build failed. The error message is “Library not found for -libPhone-lib”. This is really frustrating. I tried to find the solution online but no success. Please can someone give me tips, hints or even better a solution.

I managed to solve this. In the Unity build folder there was the file which Xcode was referencing. Somehow Xcode could not find the file so I draged it from the folder to the reference. Don’t know if this is an optimal solution but it solved my problem. I included a picture to show where in Xcode I dragged the file.