Controllers Not Tracking/Moving From Origin (OpenXR, Interaction Toolkit 2.0.2, Oculus Integration)

OpenXR controller transform not working - Unity Forum

Like in the issue linked above, I am having the problem of my controllers not tracking (moving from their origin) and need to keep the Oculus asset 40.0 as I am developing using both the Steam Index and Oculus Quest 2. The interaction system was working as intended until the Oculus Integration 40.0 asset was installed. I have remade the project numerous times and have confirmed that the asset is the root cause of the issue. I found the issue initially testing on the Steam Index and confirmed the same behavior occurs on the Oculus Quest 2.

I went by the standard setup as outlined for the XR Interaction Toolkit 2.0.2 (action-based) and I am using Unity 2021.3.4f1 for the project. Same issue occurred on Unity 2020.3.31f1 using the same packages/assets.

Setup Links
Installation | XR Interaction Toolkit | 2.0.2
Samples | XR Interaction Toolkit | 2.0.2 (setup XRI Defaults)
General setup | XR Interaction Toolkit | 2.0.2
Locomotion | XR Interaction Toolkit | 2.0.2

I have separate game objects for the locomotion system (which has added components for continuous turn/move), XR interaction manager, and input action manager (already has XRI default input actions under its Action Assets). I also confirmed that the inputs are still working for other interactions as the locomotion system still worked (i.e. registered inputs and moved player [XR Origin] accordingly) and I could also change the XR Origin>Tracking Origin Mode to Device to "lift" the devices off the floor then use the ray interactor on the controllers to grab a grab interactable object. The controllers also still rotate based on input; they just will not move from the origin/starting position. Does this bug apply? Unity Issue Tracker - XR Plugin Management - Oculus + disabled OpenXR w/ Oculus Touch Profile causes controller tracking issues. (unity3d.com)

Having the same issue...

Same issue here. I have also found out that:

  • if I uncheck the "OculusXR Feature" in XR Plugin Management (and then ignore all the popups that show up saying I should enable it) it starts working ok again. But obviously then none of the integration features work. This is clearly something to do with the Oculus Integration plugin.
  • if I use device based interactors instead of action based, they sort of work. I say sort of, because the objects I grab get into weird angles/rotations (like upside down and such) while the action based interactors moved and grabbed objects in a more polished manner.

I have also verified that despite the transform not moving around in game, the actual inputs from the physical controllers are correct and show changes in position, button clicks are also registered (tested via input debugger and xr interaction debugger).

I'm not sure if its the same issue but I upgraded from 2020.3.21 where everything worked to 2021.3.1 and Oculus link would not work at all on 2 different machines. So I upgraded to 2021.3.5 and link works now but I cannot get the oculus quest controllers to move at all with an action based rig. only a device based rigged. Did you ever find out anything as far as OpenXR and the controllers not working?

Unfortunately not - it’s still not working for me. I tried everything I could think of.

The only possibilities I could see are:
- rewriting everything I have with OVR components instead of using the OpenXR rig (which will be a lot of work at this point) or
- using device based rig which sucks and makes my game look unprofessional or
- not develop for Oculus platform or
- waiting for someone to fix this, which could be never. Given that device based rig works, the issue could be with the input manager, but I have no idea why the integration package would break it

I will try downgrading unity version to see if that works though. I tried older versions but not that particular one. I’ll comment my findings.

1 Like

Ok. I tried a fresh new project with unity version 2020.3.21f1 and everything appears to work as expected. It has the same version of interaction toolkit (2.0.2) and the same version of oculus integration plugin (v41).

I then upgraded the project to 2021.3.5f1 and the controllers stopped working (stuck to the floor, as described above). OP mentioned this not working on 2020.3.31f1 so it must have broken somewhere between 2020.3.21f1 and 2020.3.31f1.

1 Like

I tried 2022.1.7 and selecting Oculus Plugin still didn't work for the hands with an Action Based Rig, but I switched to OpenXR and included the Oculus Touch profile and the hands then worked with the Oculus Quest 2 controllers using an Action Based Rig on both 2022.1.7 and 2021.3.5 LTS

You’re saying you switched to it - so you weren’t using OpenXR to begin with?

Hey @mrekuc ,
I will give this a try today and see if I can reproduce it on our end.

If you still have a trimmed down version of the project exhibiting this behavior, can you submit a bug report? That would be super helpful for us. You can do so by going to Help > Report a Bug... in the Unity Editor. We triage bugs twice a week and tend to prioritize bugs like this.

@OP Having a very similar problem. I'm using Unity 2021.3.4f1 and XRI Toolkit 2.0.2, developing on a Windows 11 desktop with my target platform being the Quest 2. When I hit Play in the editor, the headset tracks fine (with some minor jittering), but the controllers don't track at all. When I do Build & Run, and build directly onto the Quest, the hand controllers track just fine. I started another forum thread to ask for answers, and also asked on Stack Overflow.

@BTKeevan ,
Are you using the OpenXR plugin with the Oculus Touch Controller Profile added or just the Oculus plugin?

@VRDave_Unity I've been selecting Oculus under plugin providers, because another weird thing that's been happening is that when I select OpenXR (with the Oculus Touch Controller Profile added) as the plugin provider, it doesn't track the headset or the controllers, and the scene doesn't even display in the headset.

1 Like


I tried downgrading from 2021.3.4f1 to 2020.2.21f1 to see if I could playtest in editor, hand controllers and all. Enough changes have been made to the project that I'm met with compiler errors and package errors and have to launch in safe mode. Reverted changes so the project's back in 2021.3.4f1.

You need to do it manually I think - create a fresh project in older unity version, export contents of the old project and import it into the new one. Changing a version in the hub to a prior version has never led to a success for me.

I’m trying to recreate the problem for a bug report now that I’m back from holidays. I also noticed there’s a new LTS version now so will try to upgrade too.


I can certainly try rolling back versions and remaking the project manually; albeit, I'm working as part of a small team and we're trying to meet soft deadlines in our production cycle, so it might cause a little bit of a hiccup, but at the same time we're only three weeks in and still in the prototyping phase so might not be a big hiccup at all.

I feel you, I’m not very happy about this myself. My project is further down the line, so it’s frustrating having to rebuild everything. I’m holding out hope that this might get fixed in time, but I really want to release in December so if this is what I have to do then that’s what it is.

2021.3.6f1 is broken too in case anyone is wondering. Additionally, I can’t actually see XR Interaction Toolkit in Package manager when opening a fresh project in 2021.3.6f1 version, so I’m going to recreate the bug by upgrading to it from a functional version.

1 Like

Submitted under IN-9698

I'm having the same problem. Can't see the red rays from the controller and no buttons work, but the thumb toggle will allow me to rotate my head.

I got it to work. I turned off the oculus plugin in the XR Plug-in Management screen.

1 Like