Copy file failed access is denied

After installing unity for the first time I’ve received this error. I’ve uninstalled and reinstalled at least 3 times, i’ve tried different builds same thing. I’m using windows 10, and im running it as admin,

if anyone knows how to fix this i would be thankful.

Weirdly enough, this kind of error happened to me simply because I have a Windows Explorer opened on a folder I was trying to move. My fix was simply to close that window.

An access denied error generally means that folder/file is opened somewhere else and made a “lock” on it, preventing other apps from deleting/moving that file/folder. So check what other programs you have running, and make sure they don’t have the folder/file in question opened.

The cause of my file access denied issues was actually very simple: Google Drive. Even though I hadn’t told it to include my project files in the file sync, it was still including them anyway. And the very annoying fact was if a file was syncing, access to it was locked on my PC. I disconnected my Drive and all the errors went away. I’ll just have to stick with the web interface, I guess.

Closed visual studio and problem was solved

After many hours of research I am back with the solution. I found this post:

I found packages unityeditor-cloud-hub-0.0.1.tgz and unity-editor-home-0.0.7.tgz in C:\Program Files\Unity\Editor\Data\Resources\Packages. Create folders node_modules\unityeditor-cloud-hub and node_modules\unity-editor-home in C:\Users%user_name%\AppData\Roaming\Unity\Packages. Extract dist and package.json from unityeditor-cloud-hub-0.0.1.tgz into unityeditor-cloud-hub, dist and package.json from unity-editor-home-0.0.7.tgz into unity-editor-home

and because it was a bit old it didn’t solve the solution completely, I’m guessing. Inside your install location (C:\Program Files\Unity\Editor\Data\Resources\Packages) you may also find “unityeditor-collab-history-0.4.10.tgz” and “unityeditor-collab-toolbar-0.4.12.tgz” you must also create folders for those in the Appdata folder and extract them to their respective folder.

Here is an image showing the 3 layers of my AppData folder and an image of my install location Packages folder. ![1]

Image Link (

Use Resource Monitor → Associated Handles, search for the filename, find the process that uses it and right click, end process.

Close out of Visual Studio or whatever you use to code. It’s basically the same as when you move a file in Windows Explorer and it says cannot move/copy because the file or the folder is open in another app.