CreateAssetMenu not working

I’m trying to use createassetmenu to make a character and its not showing up. What am I doing incorrect? Using 2022.3.11f1

public enum AbilityScore
{
    Strength,
    Agility,
    Vitality,
    Grit,
    Magic,
    Charm,
    Luck,
    Power,
}
[Serializable]
public class Ability
{
    public int abilityScore;
    public CharacterAbility ability;

    public Ability(CharacerAbility ability, int AbilityScore)
    {  
        this.ability = ability;
        this.abilityScore = abilityScore;
    }
}
[CreateAssetMenu(fileName = "UnnamedCharacter", menuName = "Create Character",order = 2)]
public class Character : ScriptableObject
{
    public List<Ability> abilities;
    void Reset()
    {
        abilities = List<Ability>();
        abilities.Add(new Ability(CharacterAbility.Strength, 10));
        abilities.Add(new Ability(CharacterAbility.Agility, 10));
        abilities.Add(new Ability(CharacterAbility.Vitality, 10));
        abilities.Add(new Ability(CharacterAbility.Grit, 10));
        abilities.Add(new Ability(CharacterAbility.Magic, 10));
        abilities.Add(new Ability(CharacterAbility.Charm, 10));
        abilities.Add(new Ability(CharacterAbility.Luck, 10));
        abilities.Add(new Ability(CharacterAbility.Power, 1));
    }
}

The filename has to match the class name

Thanks for the help!

Maybe getting closer but still not showing up. Here is what is says now:

[CreateAssetMenu(fileName = "Ability", menuName = "Create Character",order = 2)]

Also tried:

[CreateAssetMenu(fileName = "CharacterDB", menuName = "Create Character",order = 2)]

&

[CreateAssetMenu(fileName = "Character", menuName = "Create Character",order = 1)]
public class Character : ScriptableObject

I found a few other mistakes but its still not creating the Asset Menu. So I separated that function to it’s on script then I could also see I needed a new command before the List. Now it’s working, thanks!