"Creating unique file" error


I recently started having an error appear “Creating unique file” “Creating file assets/mainbuild/materials/Texture (forward slash) PlywoodNew0001_S.mat failed. Please ensure there is enough disk space and you have permissions setup correctly.”

The options are Try Again, Cancel, or Quit. If I cancel, it then brings up the same error with another file, and does so for 2 or 3 other files before finally opening the project file. However, when the file is open, my main building isn’t imported. If I try to reimport that model, I get the same series of errors again.

I’m not sure if this has anything to do with it, but the fact that the material is preceded by a forward slash instead of a backslash seems strange - but maybe fine. (the forward slash gets deleted automatically in here, so I just typed it out).

I’m definitely not out of disk space, and tried copying the entire project file to other locations on other hard drives, and get the same error.

Any help with this would be greatly appreciated!

Maybe it do not support your folder’s url language.
It’s all right after changed the folder’s url from chinese to english.

Tested on Windows.

I have the same problem with a material file/name on few projects. I have no idea what happening. No strange characters on name, no chinese url.

I think cause by collision of hashes
Rename those material files

Well I think you need to delete the material’s meta file and try it again
It works for me