CSV file formatation

I changes the Computer and since then, my -CSV file changed numbers Like 1.2 to first February…
I changed “standard” to “text”, but when I close the file and reopen it, the formation is gone again…#
I tried to change it in .txt. but it doesnt work either. When I close it, the formatation is changed again (3.4 to third of april or so).

But If I write 1,2 instead of 1.2 Unity doesnt now the “,” It will see it like 12.

What can I do?

CSV files are just plain text files and do not have any formatation. You probably talk about some software like excel or open office calc which let you view and edit CSV files as a table. However since there’s no format stored in the file itself, how the different cells are displayed inside those programs is either a setting or an arbitrary choice of those programs. This has nothing to do with Unity.

Also note that CSV is not a standard by any means. It could mean either “Comma Seperated Values” or “Character Seperated Values”. Especially in locals that use the comma as decimal point, excel will use a semicolon to seperate the fields in CSV exports.

So you may want to check the settings of the program you use to view / edit your CSV files or get a different program to edit your files. Another solution is to actually store the file in the native format of your favourite program and just do a CSV export for the use in Unity. That way you can keep all advanced features as well as the cell format in your spread sheet and just export the raw data into a seperate file for Unity when you changed something in your source file.