currently selected scripting backend(il2cpp) is not installed

I just installed Unity2017.2.0
Error while building "currently selected scripting backend(il2cpp) is not installed"
How can fix? thank
3294043--255242--擷取.JPG

2 Likes

In Unity installer, select "Windows Store IL2CPP scripting backend" component.

25 Likes

Hi,
Is there any way to download the IL2CPP scripting backend installer without using the whole assistant please ?

3 Likes

No, I don't think this is possible now.

1 Like

@kookyoo It is possible if you use the newly released Unity Hub to download and manage your Unity versions. Killer functionality IMO.

10 Likes


Thanks!

1 Like

Please bring back unique downloads of each install component. It saves downloading everything multiple times for each computer.

PLEASE.

This kind of service regression, in light of how frequent updates are, is unwelcome.

3 Likes

You can use the offline deployment method to download individual unity components. :)

https://docs.unity3d.com/Manual/DeployingUnityOffline.html

5 Likes

THANK YOU!!

I'm already well through using the normal installer, but haven't used the custom install to specify a download folder. In this situation, can I find the downloads on my computer somewhere?

and... how would somebody become aware of this feature if they don't already know about it?

1 Like

To those working at Unity who care about the user experience, the number of topics needed to explain installing Unity might be a key indicator something's wrong with the way you desire your users to install their software:

3686992--303310--Screen Shot 2018-09-17 at 9.02.41 pm.png

5 Likes

Yes, it is true that the entire Unity have to be re-installed by selecting the needed packages. I was also facing similar issue which is quoted here. I switched to the newest version and checked the packages at the very beginning of the Unity installer and things got working after that!


Great to know, yet you don't say HOW.

1 Like

Here:

11 Likes

and few months later they removed "Add Component"... f*ing amazing.

6 Likes

It was just renamed to "Add modules". Not removed:

4750040--450827--upload_2019-7-15_15-7-14.png

12 Likes


When you added editor in HUB via "LOCATE", you don't have option "Add Modules".
Only when you install editor via HUB.
That was the problem.

I figured it out 10 min later and i wanted to edit my comment, but i couldn't find this topic...
I remember in past i could find list of all my posts in my profile page.
Am i blind, or forum lost some functionality?

Click on your user name -> Find all content by OneManArmy3D

1 Like


Got ya. I was clicking on my username in top right corner and it opens account page. But if you hover over username then pops up window where you can open Profile Page and Your Content.
Thanks.

Hey, The IL2CPP module is missing for Unity 2019.3b, is there an estimate on release or is my unity hub bugged?

1 Like

https://unity3d.com/unity/whats-new/2019.2.4
here download il2cpp
download center unity.

5 Likes